Edit in Descript Outage
Resolved

This incident has been resolved.

Wed, Sep 25, 2024, 04:36 AM
(6 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Wed, Sep 25, 2024, 04:36 AM

Investigating

We are currently investigating an issue that is preventing users utilizing the Edit in Descript function. As a temporary workaround, we recommend downloading the files and uploading to Descript manually.

Wed, Sep 25, 2024, 03:59 AM(37 minutes earlier)