Transcriptions are failing
Incident Report for Descript
Resolved
This incident has been resolved.
Posted Aug 16, 2022 - 15:33 PDT
Investigating
We are currently investigating this issue.
Posted Aug 16, 2022 - 12:12 PDT
This incident affected: Transcription.