Transcriptions are taking longer than usual to complete
Resolved·Degraded performance

This incident has been resolved.

Wed, Aug 17, 2022, 05:58 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Aug 17, 2022, 05:58 PM

Investigating

We are currently investigating this issue.

Wed, Aug 17, 2022, 05:09 PM(49 minutes earlier)