Payments Outage
Resolved

The incident has been resolved. Impacted customer accounts have been fixed and any relevant refunds are processed.

Tue, Mar 14, 2023, 06:06 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

The incident has been resolved. Impacted customer accounts have been fixed and any relevant refunds are processed.

Tue, Mar 14, 2023, 06:06 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Mon, Mar 13, 2023, 07:21 PM(22 hours earlier)

Identified

An issue with new Creater/Pro accounts causing premature subscription termination has been identified. The fix is being rolled out and we are actively working to refund impacted customers. If there are any issues or concerns, please do not hesitate to contact support.

Mon, Mar 13, 2023, 05:54 PM(1 hour earlier)