Delays in publishing projects
Incident Report for Descript
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 15:41 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 16, 2020 - 14:01 PST
Identified
The publish queue was backing up. Extra resources have been added to help mitigate the load.
Posted Dec 16, 2020 - 13:18 PST
This incident affected: Publishing.