Resolved
This issue is now resolved.
Monitoring
Functionality is fully restored and we are monitoring to ensure the system continues to be operational.
Identified
We have identified the underlying issue and are working to restore functionality.
Investigating
We have detected a problem with importing files via the Edit in Descript feature and are investigating the underlying issue. This may affect projects imported directly from Squadcast, as well as third party services. As a workaround, please download and upload the files manually. We will update as soon as we have more information.