Resolved
We tracked down the root cause of the issue to a quota limitation on the backend. That quota has been raised and AI Speakers are now training successfully again
Investigating
We are currently investigating why some users may not be able to create new AI Speaker voices. Existing AI Speakers and Stock AI Speakers should be able to generate AI Speech without issues, but attempts to generate TTS or use Regenerate with recently-created custom speakers may fail as well