Google Cloud Outage
Resolved·Full outage

This issue is now resolved.

Thu, Jun 12, 2025, 09:35 PM
(3 weeks ago)
·
Affected components
Desktop App
Web App
Updates

Resolved

This issue is now resolved.

Thu, Jun 12, 2025, 09:35 PM

Monitoring

Functionality is fully restored in Descript and we are monitoring to ensure the system continues to be operational. Squadcast services are still currently down. We are investigating and will update as soon as more information as it becomes available.

Thu, Jun 12, 2025, 08:57 PM(38 minutes earlier)

Investigating

We have detected a problem and are investigating the underlying issue.

Thu, Jun 12, 2025, 06:33 PM(2 hours earlier)

Investigating

Due to an issue with Google Cloud Services, Some Descript functions are not working. We are currently investigating and will update as soon as we have more information.

Thu, Jun 12, 2025, 06:28 PM