Drives and pages loading slowly
Resolved·Degraded performance

This issue is now resolved.

Mon, May 26, 2025, 05:18 PM
(2 months ago)
·
Affected components
Desktop App
Web App
Updates

Resolved

This issue is now resolved.

Mon, May 26, 2025, 05:18 PM

Monitoring

Functionality is fully restored and we are monitoring to ensure the system continues to be operational.

Mon, May 26, 2025, 04:54 PM(23 minutes earlier)

Investigating

We have detected an issue where the drive view or drive selection loads slowly for some users. We are actively investigating and will update as soon as we have more information.

Mon, May 26, 2025, 04:06 PM(47 minutes earlier)