App Outage
Resolved·Full outage

This issue is now resolved.

Tue, May 20, 2025, 08:06 PM
(2 months ago)
·
Affected components
Desktop App
Web App
Updates

Resolved

This issue is now resolved.

Tue, May 20, 2025, 08:06 PM

Monitoring

Functionality is fully restored and we are monitoring to ensure the system continues to be operational.

Tue, May 20, 2025, 07:54 PM(11 minutes earlier)

Investigating

We are currently investigating an issue that is preventing users from opening projects or opening projects from their drive view.

Tue, May 20, 2025, 07:36 PM(17 minutes earlier)