Some users are unable to open the Desktop app to a usable window
Resolved·Partial outage

The issue impacting loading the desktop app is now resolved.

Tue, Mar 4, 2025, 05:18 PM
(1 month ago)
·
Affected components
Desktop App
Updates

Resolved

The issue impacting loading the desktop app is now resolved.

Tue, Mar 4, 2025, 05:18 PM

Investigating

We are continuing the investigation. While we do so, we are encouraging users who encounter this issue to try the web version of Descript at web.descript.com, which is not affected by this problem. It has almost the same feature set as the Desktop app and so should allow most people to work around this issue.

Fri, Feb 14, 2025, 01:15 AM(2 weeks earlier)

Investigating

Some Desktop app users are unable to get past a "loading" screen when they open the app. We are currently investigating the underlying issue.

Thu, Feb 13, 2025, 07:22 PM(5 hours earlier)