Project edits are not saved properly and being lost
Resolved·Full outage

This incident has been resolved.

Tue, May 16, 2023, 05:26 PM
(2 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Tue, May 16, 2023, 05:26 PM

Monitoring

We have additionally disabled a third-party integration that was affecting the sync performance of the app. We now believe the system to be back to full functionality, and we will continue to be monitoring the situation

Sun, May 14, 2023, 01:56 AM(2 days earlier)

Monitoring

We have released several fixes to the app that will resolve data loss issues, as well as adding more reliability to the automatic backup system.

We are continuing to monitor systems and customer communication to ensure we have resolved all issues.

Sat, May 13, 2023, 12:29 AM(1 day earlier)

Investigating

We have multiple reports of project edits not being saved and synced properly and subsequently being lost. We are currently investigating the issue and have bug fixes in progress.

Thu, May 11, 2023, 08:30 PM(1 day earlier)