Resolved
We've deployed the fix and the issue is now resolved.
Identified
We have identified the underlying issue and are working to restore functionality.
Investigating
Some larger projects are becoming unresponsive for ~20 seconds after making simple edits. Not all projects are affected by this, and the edits are being synced to the cloud successfully. We are currently investigating the underlying issue.